Prelink for Maya  is a plug-in that allows Autodesk Maya to transmits animation data transforms over the network into a Previzion system for real-time character and object animation.

This enables any motion capture system that integrates with Maya to be used with Previzion, and take advantage of Previzion’s frame-accurate time sync and optically matched renderer. This also enables any Maya animations to be used with Previzion.

Adding objects to animate is a simple task of dragging and dropping animated nodes to the new prelinkNode inside Maya. This allows artists to work in an environment they’re comfortable with and use all the animation controls they already work with.

Installation Process

For Maya 2012 and 2013

Download Prelink for Maya/MoBu 2012/2013 from the Dashboard.

Unzip the Prelink installation folder and run the InstallPrelink2012×64.exe.

Follow the instructions to install Prelink.

If you have MotionBuilder as well, install the plug-ins. If not, disable the installation of MoBu Prelink/Precam.

prelinkmenu1

Use the repair setting of the HASP Run-time Setup.

prelinkmenu2

If you receive a redistributable error like this, disregard and close, everything will still work with the newer version.

prelinkmenu3

Once installation is complete you can use Prelink with Maya 2012, using the same methods as before. Be sure the prelinkNode.mll plug-in is loaded in the Plug-in Manager.

For Maya 2011

This alpha release requires the Microsoft Visual C 2010 Runtime libraries be installed.
  • Download the Microsoft Visual C 2010 Runtime
  • Download and install the license key driver.
  • Download Prelink for Maya/MoBu 2011 from the Dashboard.
  • Place libprelink.dll in Maya’s bin (C:\Program Files\Autodesk\Maya\bin).
  • Place prelinkNode.mll in Maya’s plug-ins directory (C:\Program Files\Autodesk\Maya\bin\plug-ins).
  • Load Prelink using the Plug-in Manager in Maya: Window > Settings/Preferences > Plug-in Manager Next to prelinkNode.mll check the boxes for “Loaded” and “Auto load”

Using Prelink

Prelink is implemented as a Maya ObjectSet. Only DAG nodes can be transmitted.

Creating prelinkNode

  • To create a prelinkNode type createNode prelinkNode in the MEL command line and hit Enter.
  • Open the Outliner  under Window > Outliner
  • To select all the joints in a scene, e.g. if the scene has a single animated character, use Edit > Select All by Type > Joints
  • To add nodes simply middle mouse button drag them onto the ObjectSet(prelinkNode1), or select them and use the “sets” command, (e.g. sets -edit -forceElement prelinkNode1)

Transmitting Data

  • To begin transmitting updates to Previzion, open the prelinkNode, then open its “Extra Attributes” and set the server address and port, then check “Server Open”
  • The “Server Connected” checkbox indicates if the connection was made. It unchecks if the connection is lost, e.g. if the server address or port are edited the connection is closed. You must exit the editing mode for the address and port fields before a connection can be re-established.
  • The transmission rate is given by the Maya timeline. It is recommended to set Maya Preference: Window > Settings/Preferences > Preferences > Settings > Time Slider > Playback > Playback Speed to Real-time (24fps), or what the animation is set for.
  • Nodes in the object set can be operated on in the GUI, or animation played. Either way their transforms will be sent to Previzion.
  • Only the transforms in the prelinkNode are sent. Operating on a node, e.g. translate or rotate, will not be sent to Previzion.
 

Common problems:

If you encounter a message similar to “Failed to load dynamic library” when you attempt to load the plugin, it is likely that either the license key driver or libprelink.dll are not installed correctly. If the server (Previzion) goes down, the plug-in will not yet report that.

Known bugs:

Some callbacks fail to clear. This may leak memory or reduce performance after multiple add/remove cycles.

Last Modified: August 4, 2014