{{LEFT}}

Overview

This tutorial will go over how to take the Previzion Take Data from production, and use it to refine the track and get it ready for post-rendering. Note: This method is optimal mainly for shots with very minimal to no lens distortion.

Take Converter

To start we need to use the Take Converter to write the proper file to import into SynthEyes.

  • Start by Browsing for your Takes directory, then select the take you want to work with.
  • If need be, cut down the length of the take by adjusting the Timecode In/Out. Note: Write down the ending timecode in/out, and frame count for reference when sequencing the video.
  • Name the Output of the file and hit Queue.
  • Browse for the proper Output Directory
  • Check off necessary Output Formats and hit Convert

Image sequencing

Extract all frames of the shot by using Quicktime Pro

File > Export > Export: > Movie to Image Sequence

………………> Options > Format: PNG or other lossless format.

You can use any program you wish to extract frames, this is just a simple easy way to do so.

Importing Shot

File > Import > Shot

synth2

  • Set Start Frame at 0, and End Frame one less than the frame count.
  • Set Frame Rate to match source.
  • Set Queue Length to frame count of shot.
  • Find the Back Plate width in the bottom of the .dae, take file, under Sensor Width. This will be a camera specific parameter. This example was from a Sony FS700.

synth3

SynthEyes

synth

These highlighted icons are the “go to” icons you will be using when working with SynthEyes.

  1. Feature Panel
  2. Tracking Panel
  3. Graph Editor
  4. Lens Panel
  5. Solver Panel
  6. Coordinate System Control Panel
  7. Viewport Menu
  8. Active Camera

Under Edit > Edit Preferences 

  • Ensure Y Up(Maya) is selected in the first drop down.
  • Back Plate Width to Take file’s Sensor Width, change to mm.
  • Default Export Type to Maya ASCII Scene.
  • Export Units to Centimeters.
  • Maya Axis Ordering to XYZ.

Importing Camera Path

File > Import > Camera/Object Path

Import the .txt file created after processing through Take Converter

synth4

  • Set First Frame to 0 and Last Frame to match the shot length from when the shot was imported.
  • Set Axis Mode to Y Up, Right.
  • Set Rotation order to XYZ.
  • Set Zoom Channel to Focal Length.

Importing Survey Data

File > Import > Tracker Locations

Import the Example_Survey-Additional.txt from the original survey.

Graph of Trackers

When laying out tracking marks, it is best to run with the Graph Editor open.

With the Graph editor you can see the tracking progress in a color coded format:

  • Red – No solid tracking available
  • Yellow – Almost enough tracking points
  • Green – Enough tracking marks to get a good solve
  • Gray – More than enough tracking marks

synth5

Tracking Surveyed Points

Switch to the Tracking Panel to track the surveyed markers.

Start by hovering over the small yellow plus signs, these are the surveyed marks brought in with the original survey data.

When the yellow plus sign turns red, click and hold the Left mouse button. A red box within a box will appear as your curser, move this box to the proper location on the image where the survey mark is located. As shown in the image below. Use the preview box in the Tracking Panel on the left, to line up the tracker.

synth6

Next, you will want to play through the shot to let the marker track. Do this by hitting the play button at the top of the menu, circled in green below.

synth7

If you are in the middle of a shot and believe you could use this tracker during an earlier portion of the shot, change the direction to go backward, using the arrow in the menu, circled in red above.

synth12

To further lock in the position of your surveyed points, constrain them to Lock Point. This let’s SynthEyes know that these are known points and help to calculate distortion and steady the track.

{{RIGHT}}

Additional Tracking Marks

Most of the time, surveyed tracking marks won’t be enough for a good solve. You then must go through and add in manual points for tracking. Do this by selecting the create new trackers button and make sure the type is set to match, as highlighted below.

synth8

Click on different unique spots in the image and play through the shot to track them.

If you have a lot of shake in your video, you will need to enlarge the outer box on the trackers. Do this by going to the bottom-right corner of the outer box and dragging out to expand the range.

After some time setting up you should have a shot that has a collection of trackers, around 20 at any given time will usually put you in the gray in the Graph Editor.

synth9

For the best distortion solve, it is best to have a lot of markers nears the edges of the frame at all times.

Solve Track

  • In the Feature Panel
    • Change the motion configuration drop-down to Crash Pan.
  • In the Lens Panel 
    • Change the Lens Focal Length to Known.
    • Turn on Calculate Distortion.
  • In the Solver Panel
    • Change the Solution Technique drop-down to From Seed Points.
    • Enable Slow but sure.
    • In Axis Locks enable, L/R – F/B – U/D – Pan – Tilt – Roll.

Once you have all of those settings in SynthEyes, in the Solver Panel hit Go! A window will pop up showing the progress of the solve, once it is done hit Ok. Your camera should look very similar to the original path.

Before:synth10

After:synth11

Export Camera Solve

To bring the solve into Maya, go to File > Export > Maya ASCII Scene

Go to your Maya scene, File > Import, and import the solved camera path.

In the outliner, a node will be created called “group.” Open the group node and locate the Camera node.  In the attribute editor, go to the camera’s Shape node and change the Far Clip Plane to 100,000, to allow for a larger range. Next scroll down to the Environment tab and open the Image Plane node. In the Placement tab, change the Depth to 90,000 to allow the geometry to show in front of the camera plane.

For this specific tutorial, when imported into Maya, the camera solve needed to be rotated by -0.5 in the Y-axis to line up perfectly.

Before SynthEyes:

Download Video

After SynthEyes:

Download Video

Download

Download the full working project file from the Dashboard. The project includes all necessary elements, and a completed solve project.