{{LEFT}}

Overview

This tutorial will go over how to take the Previzion Take Data from production, and use it to refine the track and get it ready for post-rendering.

Constellation Tool

Download LIDAR enabled version from the Dashboard.

In Constellation Tool open the survey file by adding the points into the UI. Once loaded, export the points as LIDAR and locate them with the rest of the survey files.

Take Converter

To start we need to use the Take Converter to write the proper file to import into PFTrack.

  • Start by Browsing for your Takes directory, then select the take you want to work with.
  • If need be, cut down the length of the take by adjusting the Timecode In/Out. Note: Write down the ending timecode in/out, and frame count for reference when sequencing the video.
  • Name the Output of the file and hit Queue.
  • Browse for the proper Output Directory
  • Check off necessary Output Formats and hit Convert

Maya

Import the Maya ASCII from Take Converter into Maya.

Edit the time slider to include all frames from the selected take.

Select the Previzion camera node and go to File > Export Selection…

From there change the Preset to Autodesk Media & Entertainment

Under Advanced Options > FBX File Format

  • Type: ASCII
  • Version: FBX 2010

Export file into directory with the shot.

Image sequencing

Extract all frames of the shot by using Quicktime Pro

File > Export > Export: > Movie to Image Sequence

………………> Options > Format: PNG or other lossless format.

You can use any program you wish to extract frames, this is just a simple easy way to do so.

PFTrack

Create Shot

In the project menu at the bottom left of the UI, create a project under Projects > Create. If you don’t create a project you will not be able to continue.

Importing Shot

Enable Toggle showing File Browser at the top center of the window. Navigate to the proper directory for the image sequence, and drag the image sequence into the Tree View on the left side of the window.

Importing Camera Path

Right-Click on the shot and add Edit Camera. In the parameters window at the bottom select Import Camera. Import the fbx file that you created out of Maya. To verify the camera imported turn on the 2-H view on the right side of the window. Navigate to find the camera path.

{{RIGHT}}

Tracking

Right-Click the Edit Camera node and add a User Track. Then Right-Click the User Track and add a Survey Solver node.

In the Survey Solver parameters change the tab to LIDAR.

  • Coordinate system: Right/Y
  • Static render proxy: None
  • Dynamic render proxy: None

Import the LIDAR file you created from Constellation tool and turn on Show LIDAR. The points should appear in the 3D window with the camera path.

Tracking Surveyed Points

In the User Track you can now start adding in tracking marks.

Locate the points that have been surveyed in the scene and start with those points  to track. In the paramters window at the bottom select Create in the right function group. Click in the viewport to add the tracking mark. Modify the interior box to fit a good selection of pixels to gain a solid track through the shot. In Parameters > Deformation turn on Rotate, Scale, and Scew. Also turn on the Illumination and Blur boxes. You can then start the track by clicking the >> button. Do this until you have atleast 6 surveyed markers throughout the shot.

Next move back to the Survey Solver parameters, select the surveyed tracker,  click Attach and carefully select the corresponding survey point in the 3D viewer window. Do this to all the survey mark trackers.

Additional Tracking Marks

To get further refinement without survey marks. Create another User Track node between Edit Camera and User Track.

To add tracking marks use the same method as the surveyed trackers, without attaching them to surveyed points.

Solve Track

To solve the track go to the Survey Solver, enable Use input motion as hint and click Solve All.

Export Camera Solve

Download

Download the full working project file from the Dashboard. The project includes all necessary elements, and a completed solve project.