{{LEFT}}

Overview

To make the post process less stressful, we have made Nuke .chan files available using the tracking data from Previzion.

Prep

Constellation Editor

In Constellation Editor, use the function Export FBX, to use in Nuke to ensure the camera lines up. Reference the Constellation Editor instructions.

This FBX asset is also in the /Assets/Survey folder in the example file.

Take Converter

In Take Converter, choose your shot parameters as you would any shot, and enable the checkbox Nuke Chan. This will give you the proper file to bring into Nuke or NukeX. Reference to Take Converter instructions.

Nuke

Interface

nuke1

  1. Frame Zoom
  2. View Selection
  3. Properties Tab
  4. Node Graph Tab

Shot

To import a shot, in the Node Graph Tab, right click in the graph window and select Image > Read or hit (R) on the keyboard.

Select your image sequence and click Open.

Camera

Next import your camera by right clicking, 3D > Camera.

This will create a camera node in the graph window, now you’ll need to set a few parameters before bringing in the .chan file created in Take Converter.

In the Properties Tab, you’ll see the menu for the camera node, if not double click on the camera node in the Node Graph.

nuke2

In the Projection sub-tab, change the horiz aperture to match the Sensor Width in the original .dae take file.

nuke4

For the vert aperture, divide your horiz aperture by your Aspect Ratio, found two parameters below the Sensor Width in the take file. For example, in this case, the vert aperture is 6.97 mm/1.7778 = 3.92 mm. (Nuke assumes mm for focal length.)

nuke3

In the Camera sub-tab, change the rotation order to XYZ. Now import the .chan camera file by clicking the folder icon (directly under the display : wireframe drop-down menu), find your .chan file and click open.

{{RIGHT}}

Geometry

To ensure everything lines up, you can import the FBX created when working on the constellation for Previzion. To import, right click in the Node Graph window, 3D > Geometry > Read Geo

 

Start by importing the geometry, by clicking the folder icon on the right of the file box. Then enable the display all objects selection,  and update the display and render options to fit what you are working on. Also: uncheck read on each frame to dramatically speed up rendering!

This should be your result:

nuke_result

You don’t have to bring in the constellation geometry, but it helps to make sure everything is where it should be. You can also import in your final geometry for rendering and compositing. Change the View Selection to 3D and select fit under the Frame Zoom to show all of the objects in the scene. Navigate by holding Alt+(LMB for Pan, MMB for Zoom, and RMB for Rotate).

nuke6

Connections and Settings

Move back to the 2D view in the View Selection. Now add in a node to overlay these things into one image. Right click in the Node Graph, 3D > Scanline Render. Connect the Shot, Camera, and Geometry nodes to the Scanline Render by moving the arrows to the Scanline Render node. Now connect the Scanline Render node to the default Viewer1 node.

nuke8

The result will be a lined up path for further refinement.

nuke7

Interlaced video, Previzion and Nuke

Interlaced 50i and 60i video can be used with Nuke and Previzion data.  The only thing to be aware of is that Nuke does not handle interlaced video directly, so a plugin called “Fieldskit Deinterlace” must be used just after the interlaced source video, and again “Fieldskit Interlace” just before outputting to the “Viewer” or “Write” functions.

Nuke_Interlaed_2

The Deinterlacing function should be set to “Deinterlace (duplicate)” This will turn the 60i/50i video sequence in to a line doubled 60p/50p video sequence.  This is necessary because Nuke doesn’t know how to deal with fields, and the data that comes out of Previzion when it is set to an interlaced format is working at either 60 or 50 camera positions per second.

The Interlacing function should be set to “Interlace” this will convert your 60p/50p work back into 60i

Nuke_interlaced_1

Download

Download a sample of Nuke integration files from the Dashboard.