{{LEFT}}

Lens Calibration

Using Agisoft Lens, you can take the camera you used for a photogrammetry shoot and calibrate the lens to help with aligning photos.

This is a simple process of taking photos of your computer screen and processing them into a file.

When completed with lens calibration. Open the calibration under Tools > Camera Calibration… using the folder icon, open the calibration and click OK.

Importing Photos

To start a solve import the photos under Workflow > Add Photos… Select all of the photos you wish to align and click Open.

Masking Photos

Masking photos can help with alignment, by removing any overhanging objects that may not solve well, like power lines. Clouds can also sometimes cause issues with solving point clouds.

There are a few tool options for masking photos.

  • Rectangle Selection (M)
    • Rectangular selection to make large selections quickly.
  • Intelligent Scissors (L)
    • Polygonal selection, to quickly select around features.
  • Intelligent Paint (P)
    • Makes large selections based on color range, by clicking and moving across the image.
  • Magic Wand (W)
    • Makes large selections based on a varied color range, by clicking in areas.

After making a selection you can add to the mask by clicking Ctrl+Shift+A on the keyboard, to remove areas from the mask is Ctrl+Shift+S. Moving between images quickly can be done with the hotkeys for Next, Ctrl+] and Previous, Ctrl+[.

PG_1

Aligning

After you have gone through all of the necessary photos you can align the photos to get a sparse point cloud.

Workflow > Align Photos… Set Accuracy to High or Medium for the initial alignment.

PG_2

Chunks

Chunks can be used for a few reasons:

  • ¬†Multiple cameras, lenses, and/or focal lengths used for source images.
  • Some sections solve muddled together.

Duplicate chunks by Right clicking and selecting Duplicate. Once duplicated, remove images from chunk listings.

When multiple chunks are solved, they can then be lined up using Workflow > Align Chunks…

{{RIGHT}}

Dense Clouds

After initial alignment, building the dense point cloud will give you the information for building the points into a mesh.

Workflow > Build Dense Cloud…

Set Qaulity to High, or Ultra High. For all intents and purposes, there is not much of a difference from High to Ultra High, while Ultra High will take longer to compute.

PG_3

Meshing

Meshing the dense point cloud often produces a model in the 10 million polygon range. Later we will go over how to reduce that polygon count while preserving accuracy.

Workflow > Build Mesh… Use High settings.

PG_4

Building Texture

For quick transfer to Previzion, you can build a set of high resolution texture files to be exported with the scene.

Workflow > Build Texture…

Using Generic Mapping mode, with a texture size of 4096. Generic Mapping generates automatic atlas UV maps based on the number of textures you output. Depending on the size of the scene you should create anywhere from 4-20 textures. As a rule of thumb, one side of a 3 story building should use 2 4k maps. And the further away the objects are the lower resolution they will need.

For texture rebuilding from ZBrush:

To retexture on a simplified mesh, open the file from ZBrush and import back into the project.

Tools > Import > Import Mesh…

Once the new mesh is in Photoscan, go back through Workflow > Build Texture… and complete the textures in the same fashion.

If you’re using UVs set up in Zbrush, select Keep UVs, instead of Generic for the mapping mode.

PG_5

Exporting

For immediate export to Maya for optimization:

File > Export Model…

Save as Autodesk FBX, enable all of the check boxes, and choose the file type for the textures.

For export to ZBrush for remeshing:

File > Export Model…

Export file as Wavefront OBJ, in default settings.

Textures

JPEGs created in Photoscan will automatically add edge padding along UV seams.

PNGs will not add edge padding, but there is a Photoshop plugin called Solidify from Flaming Pear, download with this link. Place the plugin in the plugins folder in the program files for Photoshop and run the plugin over the PNG images.