{{LEFT}}

Overview

The secret to a successful transparent object is a good Alpha texture. Clean alphas are especially important when planning to finish in-camera with Previzion. This page will go over what to look for in an alpha and how to fix it, if necessary.

TextureAlpha.cgfx

This shader takes the Texture.cgfx and adds on an Alpha. You can use an Alpha sampler image or use the Color Samplers alpha channel. You are able to select which channel you would like to use.

textureAlpha

Furthermore you are able to use an Alpha clip as opposed to Alpha blend, and are able to edit the clips range.

TextureAlphaLightMultiUV.cgfx

This takes the previous shader and applies an Alpha Sampler. This shader works especially well for foliage, as you can acquire source textures that contain alpha, and render out lighting on a separate UV Set.

texturealphaLightMUVAttr

TextureAlphaLightMUV

 Setting up Multiple UV Sets

In order for these Multiple UV Set shaders to operate correctly, you will need to follow one simple guideline. The shader input “UV” requires the primary default UV Set. This means when viewing the UV Sets in Create UVs > UV Set Editor, the top UV Set is the default, in this case map1. “UV2” can then be filled with the second UV Set. Look below for an example of two separate UV Sets applied to the same object.

uvSetEditor

uvs

{{RIGHT}}

Aliasing

When using an Alpha it is important not to have an aliased edge. Aliasing will cause your edges to be jagged and unrealistic. Alpha aliasing is independent of geometric aliasing, which Previzion accounts for and renders with antialiasing.

aliasing

Correcting Aliasing

Most aliasing is easy to correct with a simple blur in Photoshop.

For example, this alpha has a rather harsh edge which will not be realistic when rendered.

AlphaPoor

To fix an edge like this, simply open in Photoshop. Zoom into the edge of the alpha and use Filter > Blur > Gaussian Blur… If you set the blur between .2-1.0 you should be able to achieve a blur that is between 3 and 4 pixels wide. The 3-4 pixel blur will give you a clean edge in Previzion without aliasing. A blur larger than this will cause the alpha to have a faint “ghosting” which will not look optimal for finishing in-camera.

Alpha

Using Alpha Clip

Using the Alpha Clip setting has it’s benefits for the ability to get an infinite level of alpha stacking, without any z-fighting. The cleaner the alpha, the lower the alpha clip can be and the better it will look.

alphaClip

Creating Alphas

Photoshop

For objects that don’t have many sharp corners (less than 30°) you can do a simple selection in Photoshop. When working with an image on a white background, under Select > Color Range… you can select the range of Highlights from the Select drop down. and this will give you a solid outline of the desired Alpha. Fill this in with black and leave the section where the image exists as white. Check your edge and blur slightly if necessary.

Illustrator

If you come across a texture, such as a palm frond, that you cannot get a semi-automated alpha from you can use Illustrator. Create the outline in Illustrator, and rasterize in Photoshop.

Automated

To do a live trace, go to Object > Live Trace > Tracing Options…  use the default settings, and adjust the Threshold until the silhouette fits. After the live trace is complete use Expand on the top tracing toolbar.

Manual

Simply use the pen tool to outline the shape and bring that shape into Photoshop to adjust the blurring on the edges.

Bring the shape into Photoshop and rasterize. When the edges are properly blurred, line up the shape over the image and verify the look in Maya and Previzion.